Предположим, нам нужно хранить произвольный запрос в текстовом реквизите (строка неограниченной длины). Порядок действий:

Создаем реквизит "ТекстЗапроса" - строка неограниченной длины, многострочный ввод;

Добавляем реквизит на форму, в свойствах реквизита на форме выбираем: Вид - Поле текстового документа;

Создаем команду "КонструкторЗапроса"; 

В команду добавляем обработчик (на клиенте):

&НаКлиенте
Процедура КонструкторЗапросов(Команда)
	Конструктор = Новый КонструкторЗапроса;
	Конструктор.Текст = Запись.ТекстЗапрса;
	Оповещение = Новый ОписаниеОповещения("ОткрытьКонструкторЗапросаЗавершение", ЭтотОбъект);
	Конструктор.Показать(Оповещение);
КонецПроцедуры

&НаКлиенте
Процедура ОткрытьКонструкторЗапросаЗавершение(Текст, ДополнительныеПараметры) Экспорт
	Если НЕ Текст = Неопределено Тогда
		Запись.ТекстЗапрса = Текст;
	КонецЕсли;
КонецПроцедуры

Добавить комментарий


Защитный код
Обновить