Пример публикации прайса из 1С Управление торговли 11 на сайте в формате HTML.

Ссылка на внешнюю обработку

Код продедуры:

&НаСервере
Функция ПодключитьсяКFTPСерверу()
Соединение = Новый FTPСоединение(
"ftpserver.ru", // адрес ftp сервера
21, // порт
"user", // логин
"password", // пароль
Неопределено, // прокси не используется
Истина, // пассивный режим работы
0, // таймаут (0 - без ограничений)
Неопределено // незащищенное соединение
);
Возврат Соединение;
КонецФункции

&НаСервере
Процедура ЗаписатьФайлНаСервере()

Соединение = ПодключитьсяКFTPСерверу();
Соединение.УстановитьТекущийКаталог("/public_html/");

ТекстовыйДок = Новый ТекстовыйДокумент;

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЦеныНоменклатурыСрезПоследних.Номенклатура.Артикул КАК Артикул,
| ЦеныНоменклатурыСрезПоследних.Номенклатура КАК Номенклатура,
| ЦеныНоменклатурыСрезПоследних.Цена КАК Цена
|ИЗ
| РегистрСведений.ЦеныНоменклатуры.СрезПоследних(
| ,
| ВидЦены = &ВидЦены
| И Номенклатура.ПометкаУдаления = ЛОЖЬ) КАК ЦеныНоменклатурыСрезПоследних";

Запрос.УстановитьПараметр("ВидЦены", Справочники.ВидыЦен.НайтиПоНаименованию("Мин цена продажи"));
РезультатЗапроса = Запрос.Выполнить();
Выборка = РезультатЗапроса.Выбрать();

//Текст файла начало
ТекстовыйДок.ДобавитьСтроку("<h3 align = ""center"">Прайс</h3>");
ТекстовыйДок.ДобавитьСтроку("<table border = ""1"" align = ""center""><tbody>");
ТекстовыйДок.ДобавитьСтроку("<tr><td><b>Артикул</b></td><td><b>Товар</b></td><td><b>Цена</b></td></tr>");
Пока Выборка.Следующий() Цикл
ТекстовыйДок.ДобавитьСтроку("<tr><td>" + Выборка.Артикул + "</td><td>" + Выборка.Номенклатура + "</td><td>" + Выборка.Цена + "</td></tr>");
КонецЦикла;
ТекстовыйДок.ДобавитьСтроку("</tbody></table>");
//Текст файла конец

ВременныйФайл = ПолучитьИмяВременногоФайла("html");
ТекстовыйДок.Записать(ВременныйФайл);
Соединение.Записать(ВременныйФайл,"testprice.html");

КонецПроцедуры

Добавить комментарий


Защитный код
Обновить