Создание элемента Справочника:


Процедура ЗаписатьВСправочникНаСервере()
       
    НовыйЭлемент = Справочники.Организации.СоздатьЭлемент();
    НовыйЭлемент.Родитель = Справочники.Организации.НайтиПоКоду("000000002");
    НовыйЭлемент.Наименование = "ООО Ромашка";
    НовыйЭлемент.Записать();
   
КонецПроцедуры

Создание группы:


Процедура СозданиеГруппыНаСервере()
   
    НовыйЭлемент = Справочники.Организации.СоздатьГруппу();
    НовыйЭлемент.Наименование = "Новая группа";
    НовыйЭлемент.Записать();
   
КонецПроцедуры

Удалить элемент Справочника по коду:


Процедура УдалитьЭлементСправочникаНаСервере()
   
    Объект = Справочники.Организации.НайтиПоКоду("000000007").ПолучитьОбъект();
    Объект.Удалить();
    //Примечание: НайтиПоНаименованию действует только для предопределенных элементов
       
КонецПроцедуры

Очистить Справочник:


Процедура ОчиститьСправочникНаСервере()
   
    Выборка = Справочники.Организации.Выбрать();
    Пока Выборка.Следующий() Цикл
        Объект = Выборка.ПолучитьОбъект();
        Объект.Удалить()
    КонецЦикла;
   
КонецПроцедуры

Добавить комментарий


Защитный код
Обновить