Программное редактирование пользователей позволяет создавать, удалять, редактировать пользователей, назначать права.

Создание пользователя и назначение роли:


Процедура ДобавитьПользователяИБ()
                   
    Пользователь = ПользователиИнформационнойБазы.СоздатьПользователя();
    Пользователь.Имя = "Иван";
    Пользователь.Пароль = "12345";
    Пользователь.ПоказыватьВСпискеВыбора = Истина;
    Пользователь.Роли.Добавить(Метаданные.Роли.АдминистраторСистемы);
    Пользователь.ОсновнойИнтерфейс = Метаданные.Интерфейсы.Общий;
    Пользователь.Записать();
   
КонецПроцедуры

Удаление пользователя (поиск по наименованию):


Процедура УдалитьПользователяИБ()
                   
    Пользователь = ПользователиИнформационнойБазы.НайтиПоИмени("Администратор");
    Пользователь.Удалить();
   
    Пользователь = ПользователиИнформационнойБазы.ТекущийПользователь();
    Пользователь.Удалить();
   
КонецПроцедуры

Вывести список пользователей ИБ


Процедура ВывестиПользователейИБ()
                   
    Список = ПользователиИнформационнойБазы.ПолучитьПользователей();
   
    Для каждого Пользователь Из Список Цикл
        Сообщить(Пользователь);
    КонецЦикла;
   
КонецПроцедуры

Добавить комментарий


Защитный код
Обновить