Один из способов передачи таблицы значений с сервера на клиент - передать массив структур.
Пример:

&НаКлиенте
Процедура ПолучитьАвтомобили(Команда)
    МассивЗначенийАвтомобили = ПолучитьАвтомобилиНаСервере();
   
    Для Каждого Элемент Из МассивЗначенийАвтомобили Цикл
        НоваяСтрока = Объект.Автомобили.Добавить();
        НоваяСтрока.Автомобиль = Элемент.Автомобиль;
        НоваяСтрока.ГосНомер = Элемент.ГосНомер;
        НоваяСтрока.Цвет = Элемент.Цвет;
    КонецЦикла;
КонецПроцедуры

&НаСервере
Функция ПолучитьАвтомобилиНаСервере()
       
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        | ТранспортныеСредства.Автомобиль,
        | ТранспортныеСредства.ГосНомер,
        | ТранспортныеСредства.Цвет
        |ИЗ
        | Справочник.ТранспортныеСредства";
       
    РезультатЗапроса = Запрос.Выполнить();
   
    Выборка = РезультатЗапроса.Выбрать();
    МассивЗначенийАвтомобили = Новый Массив;
    Пока Выборка.Следующий() Цикл
        СтрокаАвтомобиль = Новый Структура;
       
        СтрокаАвтомобиль.Вставить("Автомобиль", Выборка.Автомобиль);
        СтрокаАвтомобиль.Вставить("ГосНомер", Выборка.ГосНомер);
        СтрокаАвтомобиль.Вставить("Цвет", Выборка.Цвет);
        МассивЗначенийАвтомобили.Добавить(СтрокаАвтомобиль);
       
    КонецЦикла;
    Возврат МассивЗначенийАвтомобили;
КонецФункции;