Например, у нас есть excel файл со следующими графами:

Автомобиль |  Цвет

Audi               |  Красный

Ford               |  Черный

... и т.д.

Данная обработка построчно читает файл Excel и заполняет прочитанными значениями табличную часть.

Ссылка на обработку

Листинг процедуры Прочитать Файл:


&НаКлиенте
Процедура ПрочитатьФайл(Команда)
    ОписаниеОшибки = "";
    ФайлИсточник = Объект.ПутьКФайлу;
    Если ПустаяСтрока(ФайлИсточник) Тогда
        Сообщить("Не задано имя файла!");
        Возврат;
    КонецЕсли;
        Попытка
        Excel = Новый COMОбъект("Excel.Application");
        Excel.DisplayAlerts = Ложь;
        Excel.WorkBooks.Open(ФайлИсточник);
        ExcelЛист = Excel.Sheets(1);
    Исключение
        Текст = "ru = ""Невозможно открыть файл"";"
        + " en = ""Can't open file""";
        Сообщить(НСтр(Текст) + "
        |" + ОписаниеОшибки());
        Excel.Quit();
        Возврат;
    КонецПопытки;
    xlCellTypeLastCell = 11;
    ExcelЛист.Activate();
    RowCount = ExcelЛист.Cells.SpecialCells(xlCellTypeLastCell).Row;
   
    Для i = 1 по RowCount цикл        
       
        //Считываем значение ячейки
        ЗначениеЯчейкиАвтомобиль = Excel.Cells(i, 1).Value; //Автомобиль
        ЗначениеЯчейкиЦвет = Excel.Cells(i, 2).Value; //Цвет
               
       
        НоваяСтрока = Объект.ДанныеИзФайла.Добавить();
        НоваяСтрока.Автомобиль = ЗначениеЯчейкиАвтомобиль;
        НоваяСтрока.Цвет = ЗначениеЯчейкиЦвет;
       
    КонецЦикла;
   
    Excel.WorkBooks.Close();
    Excel.Quit();
    Excel = 0;       
КонецПроцедуры

Примечание. Если нужно считывать не с 1 строки - указать нужное начальное значение счетчика i.

Добавить комментарий


Защитный код
Обновить